Radkarte: Update 10.06.2011

Im Vergleich zum letzten Update wurden die folgenden Änderungen vorgenommen:

  • Die Defenition der „unbefahrbaren“ Straßen (Fahrgemeinschaftsspuren) etwas gelockert und etwas logischer gestaltet. Berücksichtigt nun auch beliebte Taggingfehler wie surface=gravel statt surface=compacted.
  • Straßen mit schlechter Oberfläche kommen in die langsame Geschwindigkeitskategorie und nie in die besten Straßenklassen. Dadurch hoffe ich wird das Routing noch etwas besser.
  • Ein Typo in dem TYP-File für das FixMe-Layer wurde beseitigt, nun gibt es auch in der Darstellung wie vorgesehen ein „mittelschweres“ Fehlen an Details.
  • Gebäude werden nur noch auf der untersten Zoomstufe (typischerweise bis 200m) angezeigt.

Zur Übersicht über die Optionen empfehle ich die Anleitung zu konsultieren.

Die Downloads sind auch bereits angepasst.

Dieser Beitrag wurde unter Allgemein abgelegt und mit , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

6 Responses to Radkarte: Update 10.06.2011

  1. 0xdeadbeef sagt:

    Obwohl ich weiß, daß Dein Hauptaugenmerk nicht auf MapSource liegt, hier ein paar Beispiele für Darstellungsprobleme in MapSource (auf meinem Oregon 450 sieht dagegen alles ok aus):

    Zum einen ist die gesamte Karte mit kleineren vertikalen und horizontalen Artefakten (graue Linien) überzogen. An einigen Stellen und in bestimmten Zoomstufen kann man sehen, daß das unsaubere Übergänge zwischen Polygonen sind:

    http://www.lemmini.de/prob1a.png (genau in der Mitte scheint eine schmale weiße Fläche zu sein, die nach rechts breiter wird) http://www.lemmini.de/prob1b.png (eine Zoomstufe weiter rein bleibt nur ein schmaler grauer Strich übrig)

    http://www.lemmini.de/prob2a.png (es zieht sich ein sehr langer dreieckiger Keil von der Mitte nach unten) http://www.lemmini.de/prob2b.png (geblieben sind drei nebeneinander verlaufende Striche)

    Ich würde mal annehmen, daß die Karte an den grauen Linien unterteilt ist und dadurch Trennlinien an Polygonen entstehen, die im originalen Material nicht vorhanden sind. Das Problem existierte schon in der originalen Radkarte, wenn auch eventuell nicht ganz so ausgeprägt. In anderen Karten in Mapsource habe ich diese Effekte noch nie gesehen. Es muß also irgendwas mit dem Exportskript zu tun haben. Eventuell Rundungsfehler oder eventuell muß man beim Aufteilen von Polygonen irgendwelche Feinheiten beachten.

    Außerdem gibt es noch das ebenfalls schon mehr oder weniger immer bestehende Problem, daß Gebiete mit sehr vielen Polygonen und POIs in einigen Zoomstufen komplett weiß bleiben:

    http://www.lemmini.de/prob3a.png (Innenstadt Frankfurt, hier ist noch alles ok) http://www.lemmini.de/prob3b.png (eine Zoomstufe bleibt hier plötzlich eine quadratische Fläche weiß) http://www.lemmini.de/prob3c.png (auf der gleiche Zoomstufe fehlen hier teils mehrere benachbarte Quadrate)

    Wobei die weißen Quadrate nicht immer exakt an der gleichen Stelle liegen, sondern ihre Lage von der Position abhängt, an der man reingezoomt hat. Wenn man auf eine andere Karte umschaltet (selbst auf die originale Radkarte), sind diese Probleme sofort beseitigt. Für mich sieht es so aus, als würde der Renderer von MapSource das Gebiet in quadratische Kacheln aufteilen (möglicherweise, um sie in verschiedenen Threads zu parallelisieren) und einige dieser Kacheln werden dann überhaupt nicht gerendert. Also ist innerhalb dieser Renderkacheln wohl irgendein Fehler (Überlauf?) aufgetreten, der zum Abbruch des Renderings geführt hat. Weil ich diesen Effekt bisher nur in Gebieten mit sehr vielen POIs und Polygonen beobachtet habe, liegt der Verdacht nahe, daß MapSource eine Beschränkung von POIs und/oder Polygonen pro Kachel hat, die das aktuelle Exportskript nicht berücksichtigt.

  2. johannes sagt:

    Zuerst einmal sorry das das Freischalten solange gedauert hat, der Kommentar wurde irgendwie als SPAM kategorisiert (vermute wegen der relativ vielen Links), und daher bekam ich keine automatische E-Mail das ein Kommentar zurückgehalten wurde.

    Bei den Artefakten habe ich eine Idee woran es liegen könnte, nutze noch zwei Patches aus der original Radkarte, wovon es einer seien könnte. Ich teste das einmal. Wenn der „Schuld“ ist kann der Wegfallen, sollte der Beschreibung nach eher verbessern als verschlimmbessern.

    Was MapSource angeht: Ich wüsste leider keinen mkgmap-Parameter der daran etwas ändert. Der Splitter liefert zu große Kacheln damit es daran liegen könnte (ca. 70 für ganz Deutschland). Das einzige was ich natürlich machen könnte wären POIs aus dem Index zu nehmen, was aber irgendwie schade wäre. Wer gute Vorschläge hat, her damit 🙂

  3. 0xdeadbeef sagt:

    Habe inzwischen rausgefunden an was es liegt und die Ursache ist eine ganz andere. Das Rendern der Karte stürzt überall dort ab, wo das kleine Kamerapiktogramm für Sehenswürdigkeiten dargestellt werden soll. In der originalen Radkarte war das eine kleine blaue Kamera. Leider sind nicht in allen Karten, die ich verglichen habe, die gleichen Sehenswürdigkeiten als POIs zu finden, daher war die Suche etwas langwierig.

    Wie auch immer, hier mal ein Beispiel: http://lemmini.de/prob4.png

    Das ist irgendwo in Offenbach, die Sehenswürdigkeit ist das größte Graffiti Hessens (man muß nehmen, was man hat). Mein Garmin zeigt da übrigens auch eine kleine Kamera an, also entweder ist das TYP-File (oder wo auch immer die Piktogramme abgelegt sind) für die Mapsource-Karten anders als das für die Erzeugung der IMG-Datei oder das Piktogramm verstößt gegen irgendwelche Konventionen von Mapsource, obwohl das Oregon sie verkraftet. Oder, last but not least, das Oregon hat einen Fallbackmechanismus auf ein Standardikon, wenn das in der Karte beschädigt ist. Oder so.

  4. johannes sagt:

    Im TYP-File gab es für diese Art der POIs ein 0x0 Pixel großes Icon, ich vermute das verursachte das Problem. Habe das nun durch ein 1×1 Pixel großes Icon ausgewechselt, und die Karten einmal neu rechnen lassen.

    Kannst du einmal schauen ob das Problem nun verschwunden ist?

  5. 0xdeadbeef sagt:

    Ja, super, das zweite (und schlimmere) Problem ist damit behoben: zumindest auf den ersten Blick gibt es keine weißen Kacheln mehr in MapSource. Auf dem Garmin habe ich das jetzt nicht probiert (falls Du das IMG überhaupt ausgetauscht hast) – sollte da die Kamera bei Sehenswürdigkeiten jetzt auch weg sein? Ich nehme ja mal an, daß die Idee von diesem Mini-Icon ist, daß man zwar danach suchen kann, es aber auf der Karte nicht angezeigt wird. Gibt es da keine elegantere Möglichkeit, bestimmte POI-Icons zu unterdrücken?

  6. johannes sagt:

    Genau, der Sinn der Mini-Icons ist viele POIs zu haben damit man die bei Bedarf finden kann, aber ohne das die (gerade in den Innenstädten) die Karte völlig unübersichtlich gestalten. Aber eine elegantere Methode kenne ich nicht, habe die quasi vom Radfahrer „geerbt“ und an einigen Stellen ausgebaut.

Kommentare sind geschlossen.